Category: Raspberry Pi

Raspberry Pi and PSK31: A work in progress

300px-RaspberryPiI spent some time up at the Voice of America club station working on getting one of my 256MB Raspberry Pi Model B working with fldigi.  The results left something to be desired…

I started with a clean copy of the latest version of Raspbian, loaded onto a brand new 8 GB Class 10 SD card.  Nothing new there.  Things went very smoothly!  My hub, keyboard, mouse and wlan USB adapter worked fine.  I loaded all of the Raspbian updates, and got fldigi to load without a hitch. Things seemed to be going swimmingly.  In Ham Radio, as in life, when things seem to be going too well, disaster is bound to strike, and this was a classic example of that.

I hooked up my Tigertronics SignaLink USB sound card interface, and things started going south.  Apparently adding this was a bit too much for the Pi to power, because the keyboard and mouse started behaving very erratically. This was easily solved by switching to a powered USB hub.

To see if the Pi had recognized the SignaLink, I typed:

$ aplay -l

And sure enough, the USB sound card was listed. Cool Beans!

Launching into fldigi, everything looked as normal – the waterfall was flowing down the bottom of my screen, everything was responding seemingly well.  We turned on the radio, and started to receive signals into the Pi…and, well, got a bunch of gibberish.  Signals appeared OK in the waterfall, but what I received in the text window was…unintelligible.

An hour’s playing around was fruitless.  Changing settings in fldigi to match the Pi’s puny processing power, fiddling with settings on the USB interface to optimize the sound to the Pi, twiddling knobs on the radio to adjust levels, and even overclocking the tiny computer to its limits, all proved futile.  A quick search on the internet showed that I’m not the only one with this issue – apparently the complexity of the calculations involved is just too much for the Raspberry Pi to handle in its current form.

I’m going to keep at it – but in the meantime, if you’ve had any luck with getting your Pi to work with the Amateur digital modes, please let me know!